Sorry, you need to enable JavaScript to visit this website.

zedboard and picozed booting

Unsolved
5 posts / 0 new
wangy's picture
wangy
Junior(0)
zedboard and picozed booting

Hello,
I want to know ,can picozed booting with QSPI like zedboard ?
For example,connect arm hw
                  source ps7_init.tcl
                 .........
 
                

JFoster's picture
JFoster
Moderator(55)
Hello Wangy,

Hello Wangy,

Yes your PicoZed can boot by QSPI. If you refer to our Zynq Software Labs : 

http://zedboard.org/course/developing-zynq%C2%AE-7000-all-programmable-s...

specifically lab 7, it goes into how to create a .mcs file that is used to program the qspi.

--Josh

wangy's picture
wangy
Junior(0)
Hello JFoster, I refered to

Hello JFoster, I refered to lab7 to program flash ,but failed,
console shows:
                                   ****** Xilinx Program Flash

****** Program Flash v2015.4 (64-bit)

  **** SW Build 1412921 on Wed Nov 18 09:43:45 MST 2015

    ** Copyright 1986-2015 Xilinx, Inc. All Rights Reserved.

 

Connecting to hw_server @ TCP:127.0.0.1:3121

 

Connected to hw_server @ TCP:127.0.0.1:3121

Available targets and devices:

Target 0 : jsn-DLC10-000014d2f51c01

Device 0: jsn-DLC10-000014d2f51c01-4ba00477-0

Target 1 : jsn1

 

ERROR: Failed to open Target Cable Node 59866048 on TCP:127.0.0.1:3121

 

How do I solve?

Thanks,

wangy,

JFoster's picture
JFoster
Moderator(55)
Hello Wangy,

Hello Wangy,

It appears you are using SDK 2015.4. We do not have any lab material that targets that version. I would suggest you update to Vivado/SDK 2016.2 any try it once more. One more question, are you starting from lab 7 using the posted lab solution or are you starting from lab 1 and building up from there?

--Josh

fletch's picture
fletch
Moderator(16)
Wangy,

Wangy,

  It should work fine in 2015.4, although Josh is correct that it is a bad idea to try a 2016.2 solution on anything other than 2016.2.

 

What O/S are you using? Did you properly install the Cable Drivers? Do you have more than one JTAG cable attached? If you do a google search for 

                        Failed to open Target Cable Node site:xilinx.com

then you will find a great number of hits and other people having the same problem.

 

Bryan